#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?![J|S|V])\w*\b|\W*"
Local $sString = "['Senior' 'Jeune,Vét,Senior' 'Senior et Vétéran' 'Vétéran' 'Jeune'" & @CRLF & _
"'Jeune et Vétéran' 'Jeune et Senior']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")