$re = '/\b(?![J|S|V])\w*\b|\W*/';
$str = '[\'Senior\' \'Jeune,Vét,Senior\' \'Senior et Vétéran\' \'Vétéran\' \'Jeune\'
\'Jeune et Vétéran\' \'Jeune et Senior\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);