import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?![J|S|V])\\w*\\b|\\W*";
final String string = "['Senior' 'Jeune,Vét,Senior' 'Senior et Vétéran' 'Vétéran' 'Jeune'\n"
+ "'Jeune et Vétéran' 'Jeune et Senior']";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}