re = /\b(?![J|S|V])\w*\b|\W*/
str = '[\'Senior\' \'Jeune,Vét,Senior\' \'Senior et Vétéran\' \'Vétéran\' \'Jeune\'
\'Jeune et Vétéran\' \'Jeune et Senior\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end