$re = '/(<p[^>]*>)(.*?)(<\/p>)|(<p[^>]*>)/i';
$str = 'one <p>two</p> three <p class="test">four</p> five <a>six</a> seven <p> eight nine <p/> ten';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);