re = /(<p[^>]*>)(.*?)(<\/p>)|(<p[^>]*>)/i
str = 'one <p>two</p> three <p class="test">four</p> five <a>six</a> seven <p> eight nine <p/> ten'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end