// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(<p[^>]*>)(.*?)(<\/p>)|(<p[^>]*>)").unwrap();
let string = "one <p>two</p> three <p class=\"test\">four</p> five <a>six</a> seven <p> eight nine <p/> ten";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}