using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img.*src="")([^""]*)("".*>)";
string input = @"<img style=""border:solid 2px #CCC;"" src=""http://teste/img.img"" />";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}