re = /(<img.*src=")([^"]*)(".*>)/
str = '<img style="border:solid 2px #CCC;" src="http://teste/img.img" />'
# Print the match result
str.match(re) do |match|
puts match.to_s
end