package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<img.*src=")([^"]*)(".*>)`)
var str = `<img style="border:solid 2px #CCC;" src="http://teste/img.img" />`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}