$re = '~(<img.*src=")([^"]*)(".*>)~';
$str = '<img style="border:solid 2px #CCC;" src="http://teste/img.img" />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);