const regex = new RegExp('(<img.*src=")([^"]*)(".*>)', '')
const str = `<img style="border:solid 2px #CCC;" src="http://teste/img.img" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}