package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)- v\d+$`)
var str = `hello world - v2
hello world - v88
hello world
hello world - v`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}