const regex = /- v\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('- v\\d+$', 'gm')
const str = `hello world - v2
hello world - v88
hello world
hello world - v`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}