$re = '/- v\d+$/m';
$str = 'hello world - v2
hello world - v88
hello world
hello world - v';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);