#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)^" & @CRLF & _
"" & @CRLF & _
"# Look for http://.../artifactory/" & @CRLF & _
"(?P<drive>https?://.+/artifactory)?/?" & @CRLF & _
"" & @CRLF & _
"# Look for anything not a '/' character" & @CRLF & _
"(?: (?P<root>[^/\n]+) /? )?" & @CRLF & _
"" & @CRLF & _
"# Look for everything else" & @CRLF & _
"(?P<remainder>.*)?/?" & @CRLF & _
""
Local $sString = "https://www.domain.com/artifactory/my-root" & @CRLF & _
"https://www.domain.com/artifactory" & @CRLF & _
"https://www.domain.com/artifactory/my-root/platform" & @CRLF & _
"http://www.domain.com/artifactory/my-root/platform" & @CRLF & _
"http://www.domain.com/artifactory/my-root/platform/Daily Gold Reserve/WW3/bin" & @CRLF & _
"single-dir" & @CRLF & _
"double/dir" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")