use strict;
my $str = 'https://www.domain.com/artifactory/my-root
https://www.domain.com/artifactory
https://www.domain.com/artifactory/my-root/platform
http://www.domain.com/artifactory/my-root/platform
http://www.domain.com/artifactory/my-root/platform/Daily Gold Reserve/WW3/bin
single-dir
double/dir
';
my $regex = qr/^
# Look for http://.../artifactory/
(?P<drive>https?://.+/artifactory)?/?
# Look for anything not a '/' character
(?: (?P<root>[^/\n]+) /? )?
# Look for everything else
(?P<remainder>.*)?/?
/mixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}