import re
regex = re.compile(r"""
^
# Look for http://.../artifactory/
(?P<drive>https?://.+/artifactory)?/?
# Look for anything not a '/' character
(?: (?P<root>[^/\n]+) /? )?
# Look for everything else
(?P<remainder>.*)?/?
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("https://www.domain.com/artifactory/my-root\n"
"https://www.domain.com/artifactory\n"
"https://www.domain.com/artifactory/my-root/platform\n"
"http://www.domain.com/artifactory/my-root/platform\n"
"http://www.domain.com/artifactory/my-root/platform/Daily Gold Reserve/WW3/bin\n"
"single-dir\n"
"double/dir\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")