$re = '/^
# Look for http://.../artifactory/
(?P<drive>https?://.+/artifactory)?/?
# Look for anything not a \'/\' character
(?: (?P<root>[^/\n]+) /? )?
# Look for everything else
(?P<remainder>.*)?/?
/mix';
$str = 'https://www.domain.com/artifactory/my-root
https://www.domain.com/artifactory
https://www.domain.com/artifactory/my-root/platform
http://www.domain.com/artifactory/my-root/platform
http://www.domain.com/artifactory/my-root/platform/Daily Gold Reserve/WW3/bin
single-dir
double/dir
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);