import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n\n"
+ "# Look for http://.../artifactory/\n"
+ "(?P<drive>https?://.+/artifactory)?/?\n\n"
+ "# Look for anything not a '/' character\n"
+ "(?: (?P<root>[^/\\n]+) /? )?\n\n"
+ "# Look for everything else\n"
+ "(?P<remainder>.*)?/?\n";
final String string = "https://www.domain.com/artifactory/my-root\n"
+ "https://www.domain.com/artifactory\n"
+ "https://www.domain.com/artifactory/my-root/platform\n"
+ "http://www.domain.com/artifactory/my-root/platform\n"
+ "http://www.domain.com/artifactory/my-root/platform/Daily Gold Reserve/WW3/bin\n"
+ "single-dir\n"
+ "double/dir\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}