using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?[1-9]*(?!0000)[0-9]{4}-(?:0[0-9]|1[0-2])-(?:0[1-9]|[1-2][0-9]|3[0-1])T(?:(?:[0-1][0-9]|2[0-3]):(?:[0-5][0-9]):(?:[0-5][0-9])(?:\.[0-9]*[1-9]+)?|24:00:00)(?:(?:\+|-)(?:(?:0[1-9]|1[0-3]):[0-5][0-9]|14:00)|Z)?";
string input = @"2015-12-31T23:00:00.34-13:33";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}