import Foundation
let pattern = #"^-?[1-9]*(?!0000)[0-9]{4}-(?:0[0-9]|1[0-2])-(?:0[1-9]|[1-2][0-9]|3[0-1])T(?:(?:[0-1][0-9]|2[0-3]):(?:[0-5][0-9]):(?:[0-5][0-9])(?:\.[0-9]*[1-9]+)?|24:00:00)(?:(?:\+|-)(?:(?:0[1-9]|1[0-3]):[0-5][0-9]|14:00)|Z)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2015-12-31T23:00:00.34-13:33"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}