use strict;
my $str = '2015-12-31T23:00:00.34-13:33';
my $regex = qr/^-?[1-9]*(?!0000)[0-9]{4}-(?:0[0-9]|1[0-2])-(?:0[1-9]|[1-2][0-9]|3[0-1])T(?:(?:[0-1][0-9]|2[0-3]):(?:[0-5][0-9]):(?:[0-5][0-9])(?:\.[0-9]*[1-9]+)?|24:00:00)(?:(?:\+|-)(?:(?:0[1-9]|1[0-3]):[0-5][0-9]|14:00)|Z)?/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}