#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:apple|mango|banana)(?:\s+(?:apple|mango|banana))*) is (\d+)kg$"
Local $sString = "apple is 2kg" & @CRLF & _
"apple banana mango is 2kg" & @CRLF & _
"apple apple apple is 6kg" & @CRLF & _
"banana banana banana is 6kg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")