package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:apple|mango|banana)(?:\s+(?:apple|mango|banana))*) is (\d+)kg$`)
var str = `apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}