re = /^((?:apple|mango|banana)(?:\s+(?:apple|mango|banana))*) is (\d+)kg$/m
str = 'apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end