const regex = /^((?:apple|mango|banana)(?:\s+(?:apple|mango|banana))*) is (\d+)kg$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:apple|mango|banana)(?:\\s+(?:apple|mango|banana))*) is (\\d+)kg$', 'gm')
const str = `apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}