import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:apple|mango|banana)(?:\\s+(?:apple|mango|banana))*) is (\\d+)kg$";
final String string = "apple is 2kg\n"
+ "apple banana mango is 2kg\n"
+ "apple apple apple is 6kg\n"
+ "banana banana banana is 6kg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}