using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*\+?\-?([\s0-9\s]{2,4}\s*)?\s*)\s*\(?([\s0-9\s]{3})\)?[-. ]?(\s*[\s0-9\s]{3}\s*)[-. ]?(\s*[\s0-9\s]{4,7}\s*)(\s*)$";
string input = @"+4487497892782
0043847352892
+4487-497892782
+4487497892782
+4487497892782
+44 8975482979
+44 8975482979
+44 8975482979
+44 8975482979
+448975482979
+4489754 82979
+4489 7 5 4 8 2 9 7 9
+44 89 7 5 4 8 2 9 7 9
+074-774-8292
074-774-8292
(074)-774-8292
004507477485
+4474-774.8292
(\s*\+?\s*([0-9][\s-]*){9,})";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}