use strict;
my $str = '+4487497892782
0043847352892
+4487-497892782
+4487497892782
+4487497892782
+44 8975482979
+44 8975482979
+44 8975482979
+44 8975482979
+448975482979
+4489754 82979
+4489 7 5 4 8 2 9 7 9
+44 89 7 5 4 8 2 9 7 9
+074-774-8292
074-774-8292
(074)-774-8292
004507477485
+4474-774.8292
(\\s*\\+?\\s*([0-9][\\s-]*){9,})';
my $regex = qr/^(\s*\+?\-?([\s0-9\s]{2,4}\s*)?\s*)\s*\(?([\s0-9\s]{3})\)?[-. ]?(\s*[\s0-9\s]{3}\s*)[-. ]?(\s*[\s0-9\s]{4,7}\s*)(\s*)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}