const regex = /^(\s*\+?\-?([\s0-9\s]{2,4}\s*)?\s*)\s*\(?([\s0-9\s]{3})\)?[-. ]?(\s*[\s0-9\s]{3}\s*)[-. ]?(\s*[\s0-9\s]{4,7}\s*)(\s*)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*\\+?\\-?([\\s0-9\\s]{2,4}\\s*)?\\s*)\\s*\\(?([\\s0-9\\s]{3})\\)?[-. ]?(\\s*[\\s0-9\\s]{3}\\s*)[-. ]?(\\s*[\\s0-9\\s]{4,7}\\s*)(\\s*)$', 'gmi')
const str = `+4487497892782
0043847352892
+4487-497892782
+4487497892782
+4487497892782
+44 8975482979
+44 8975482979
+44 8975482979
+44 8975482979
+448975482979
+4489754 82979
+4489 7 5 4 8 2 9 7 9
+44 89 7 5 4 8 2 9 7 9
+074-774-8292
074-774-8292
(074)-774-8292
004507477485
+4474-774.8292
(\\s*\\+?\\s*([0-9][\\s-]*){9,})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}