$re = '/^(\s*\+?\-?([\s0-9\s]{2,4}\s*)?\s*)\s*\(?([\s0-9\s]{3})\)?[-. ]?(\s*[\s0-9\s]{3}\s*)[-. ]?(\s*[\s0-9\s]{4,7}\s*)(\s*)$/mi';
$str = '+4487497892782
0043847352892
+4487-497892782
+4487497892782
+4487497892782
+44 8975482979
+44 8975482979
+44 8975482979
+44 8975482979
+448975482979
+4489754 82979
+4489 7 5 4 8 2 9 7 9
+44 89 7 5 4 8 2 9 7 9
+074-774-8292
074-774-8292
(074)-774-8292
004507477485
+4474-774.8292
(\\s*\\+?\\s*([0-9][\\s-]*){9,})';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);