import Foundation
let pattern = #"^(\s*\+?\-?([\s0-9\s]{2,4}\s*)?\s*)\s*\(?([\s0-9\s]{3})\)?[-. ]?(\s*[\s0-9\s]{3}\s*)[-. ]?(\s*[\s0-9\s]{4,7}\s*)(\s*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
+4487497892782
0043847352892
+4487-497892782
+4487497892782
+4487497892782
+44 8975482979
+44 8975482979
+44 8975482979
+44 8975482979
+448975482979
+4489754 82979
+4489 7 5 4 8 2 9 7 9
+44 89 7 5 4 8 2 9 7 9
+074-774-8292
074-774-8292
(074)-774-8292
004507477485
+4474-774.8292
(\s*\+?\s*([0-9][\s-]*){9,})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)