package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)(\s*\(.*?\))`)
var str = `Javascript (12+ years), Java (10 years)`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}