import re
regex = re.compile(r"(.*?)(\s*\(.*?\))", flags=re.MULTILINE)
test_str = "Javascript (12+ years), Java (10 years)"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)