use strict;
my $str = 'Javascript (12+ years), Java (10 years)';
my $regex = qr/(.*?)(\s*\(.*?\))/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";