$re = '/(.*?)(\s*\(.*?\))/m';
$str = 'Javascript (12+ years), Java (10 years)';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;