import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!s)'(?!(?:t|ll|e?m)\\b)";
final String string = "I'm one of the persons' stackoverflow don't th'em said, 'hey what' I'll handle it.";
final String subst = "\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}