import Foundation
let pattern = #"(?<!s)'(?!(?:t|ll|e?m)\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I'm one of the persons' stackoverflow don't th'em said, 'hey what' I'll handle it."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)