$re = '/(?<!s)\'(?!(?:t|ll|e?m)\b)/';
$str = 'I\'m one of the persons\' stackoverflow don\'t th\'em said, \'hey what\' I\'ll handle it.';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;