use strict;
my $str = 'I\'m one of the persons\' stackoverflow don\'t th\'em said, \'hey what\' I\'ll handle it.';
my $regex = qr/(?<!s)'(?!(?:t|ll|e?m)\b)/p;
my $subst = '"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";