re = /(?<!s)'(?!(?:t|ll|e?m)\b)/
str = 'I\'m one of the persons\' stackoverflow don\'t th\'em said, \'hey what\' I\'ll handle it.'
subst = '"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result