#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<([^>]+)>[^<]+)<\/COLUMN>"
Local $sString = "<Objects>" & @CRLF & _
" <Object>" & @CRLF & _
" <Id>1</COLUMN>" & @CRLF & _
" <Type>Type1</COLUMN>" & @CRLF & _
" <Name>Some name</COLUMN>" & @CRLF & _
" </Object>" & @CRLF & _
" <Object>" & @CRLF & _
" <Id>2</COLUMN>" & @CRLF & _
" <Type>Type2</COLUMN>" & @CRLF & _
" <Name>Some name2</COLUMN>" & @CRLF & _
" </Object>" & @CRLF & _
" </Objects>"
Local $sSubst = "\1<\/\2>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)