import Foundation
let pattern = #"(<([^>]+)>[^<]+)<\/COLUMN>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<Objects>
<Object>
<Id>1</COLUMN>
<Type>Type1</COLUMN>
<Name>Some name</COLUMN>
</Object>
<Object>
<Id>2</COLUMN>
<Type>Type2</COLUMN>
<Name>Some name2</COLUMN>
</Object>
</Objects>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1<\/\2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)