$re = '/(<([^>]+)>[^<]+)<\/COLUMN>/';
$str = '<Objects>
<Object>
<Id>1</COLUMN>
<Type>Type1</COLUMN>
<Name>Some name</COLUMN>
</Object>
<Object>
<Id>2</COLUMN>
<Type>Type2</COLUMN>
<Name>Some name2</COLUMN>
</Object>
</Objects>';
$subst = "\1<\/\2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;