import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<([^>]+)>[^<]+)<\\/COLUMN>";
final String string = "<Objects>\n"
+ " <Object>\n"
+ " <Id>1</COLUMN>\n"
+ " <Type>Type1</COLUMN>\n"
+ " <Name>Some name</COLUMN>\n"
+ " </Object>\n"
+ " <Object>\n"
+ " <Id>2</COLUMN>\n"
+ " <Type>Type2</COLUMN>\n"
+ " <Name>Some name2</COLUMN>\n"
+ " </Object>\n"
+ " </Objects>";
final String subst = "\\1<\\/\\2>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}