use strict;
my $str = '<Objects>
<Object>
<Id>1</COLUMN>
<Type>Type1</COLUMN>
<Name>Some name</COLUMN>
</Object>
<Object>
<Id>2</COLUMN>
<Type>Type2</COLUMN>
<Name>Some name2</COLUMN>
</Object>
</Objects>';
my $regex = qr/(<([^>]+)>[^<]+)<\/COLUMN>/p;
my $subst = '\\1<\\/\\2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";