import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{64}2\\)\\?\\.\\*\\\\.{204}\\\\2\\\\\\(\\)\\{2\\}\\.\\{11\\}\\$\\/$)((.*)(\\2\\2)?.*\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{64\\2\\}2\\2\\\\\\2\\)\\2\\\\\\2\\?\\2\\\\\\2\\.\\2\\\\\\2\\*\\2\\\\\\2\\\\\\2\\.\\2\\{204\\2\\}\\2\\\\\\2\\\\2\\2\\\\\\2\\\\\\2\\\\\\2\\(\\2\\\\\\2\\)\\2\\\\\\2\\{2\\2\\\\\\2\\}\\2\\\\\\2\\.\\2\\\\\\2\\{11\\2\\\\\\2\\}\\2\\\\\\2\\$\\2\\\\\\2\\/\\2\\$\\2\\)\\2\\(\\2\\(\\2\\.\\2\\*\\2\\)\\2\\(){2}.{11}$";
final String string = "abc123/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}