$re = '/^(?=.{64}2\)\?\.\*\\\\.{204}\\\\2\\\\\(\)\{2\}\.\{11\}\$\/$)((.*)(\2\2)?.*\/\2\^\2\(\2\?=\2\.\2\{64\2\}2\2\\\\\2\)\2\\\\\2\?\2\\\\\2\.\2\\\\\2\*\2\\\\\2\\\\\2\.\2\{204\2\}\2\\\\\2\\\\2\2\\\\\2\\\\\2\\\\\2\(\2\\\\\2\)\2\\\\\2\{2\2\\\\\2\}\2\\\\\2\.\2\\\\\2\{11\2\\\\\2\}\2\\\\\2\$\2\\\\\2\/\2\$\2\)\2\(\2\(\2\.\2\*\2\)\2\(){2}.{11}$/';
$str = 'abc123/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);