const regex = /^(?=.{64}2\)\?\.\*\\.{204}\\2\\\(\)\{2\}\.\{11\}\$\/$)((.*)(\2\2)?.*\/\2\^\2\(\2\?=\2\.\2\{64\2\}2\2\\\2\)\2\\\2\?\2\\\2\.\2\\\2\*\2\\\2\\\2\.\2\{204\2\}\2\\\2\\2\2\\\2\\\2\\\2\(\2\\\2\)\2\\\2\{2\2\\\2\}\2\\\2\.\2\\\2\{11\2\\\2\}\2\\\2\$\2\\\2\/\2\$\2\)\2\(\2\(\2\.\2\*\2\)\2\(){2}.{11}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{64}2\\)\\?\\.\\*\\\\.{204}\\\\2\\\\\\(\\)\\{2\\}\\.\\{11\\}\\$\\\/$)((.*)(\\2\\2)?.*\\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{64\\2\\}2\\2\\\\\\2\\)\\2\\\\\\2\\?\\2\\\\\\2\\.\\2\\\\\\2\\*\\2\\\\\\2\\\\\\2\\.\\2\\{204\\2\\}\\2\\\\\\2\\\\2\\2\\\\\\2\\\\\\2\\\\\\2\\(\\2\\\\\\2\\)\\2\\\\\\2\\{2\\2\\\\\\2\\}\\2\\\\\\2\\.\\2\\\\\\2\\{11\\2\\\\\\2\\}\\2\\\\\\2\\$\\2\\\\\\2\\\/\\2\\$\\2\\)\\2\\(\\2\\(\\2\\.\\2\\*\\2\\)\\2\\(){2}.{11}$', '')
const str = `abc123/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}